Still working on your Snake high score? Chances are you won’t be able to log into ME’s easy-to-use mobile banking app. Here are the minimum operating system versions that you’ll need to run the app.
  • Android – versions 4.4 to 7.1
  • iOS – versions 9 to 10
  • Was this helpful?
  • Yes
  • No